<!DOCTYPE html> <!--[if IE 7]><html class="ie ie7" lang="en-US"> <![endif]--> <!--[if IE 8]><html class="ie ie8" lang="en-US"> <![endif]--> <!--[if !(IE 7) | !(IE 8) ]><!--><html lang="en-US"> <!--<![endif]--> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6211574194789638",
    enable_page_level_ads: true
  });</script> <head><meta charset="UTF-8" /><meta name="viewport" content="width=device-width"><link rel="profile" href="https://gmpg.org/xfn/11"><link rel="pingback" href="https://borkena.com/xmlrpc.php"><link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://borkena.com/" /><link rel="pingback" href="https://borkena.com/xmlrpc.php" /> <!--[if lt IE 9]> <script src="https://borkena.com/wp-content/themes/adv-newspaper/inc/js/html5.js"></script> <![endif]--> <!-- This site is optimized with the Yoast SEO Premium plugin v12.7.1 - https://yoast.com/wordpress/plugins/seo/ --><title>Eritrean President : &quot;it was like a two months long visit&quot;</title><meta name="description" content="Eritrean President has concluded his working visit to Ethiopia. He reportedly said he felt as if it was two months. Read more."/><meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/><link rel="canonical" href="https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/" /><meta name="twitter:card" content="summary" /><meta name="twitter:description" content="Eritrean President has concluded his working visit to Ethiopia. He reportedly said he felt as if it was two months. Read more." /><meta name="twitter:title" content="Eritrean President : &quot;it was like a two months long visit&quot;" /><meta name="twitter:site" content="@zborkena" /><meta name="twitter:image" content="https://borkena.com/wp-content/uploads/2019/12/Isaias-_-Abiy-_-Eritrean-President-_.jpg" /><meta name="twitter:creator" content="@zborkena" /> <script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://borkena.com/#website","url":"https://borkena.com/","name":"Borkena Ethiopian News","description":"Latest Ethiopian News,Videos,Music,Sports,Travel,Business&amp; More","publisher":{"@id":"https://borkena.com/#/schema/person/"},"potentialAction":{"@type":"SearchAction","target":"https://borkena.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"ImageObject","@id":"https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/#primaryimage","url":"https://borkena.com/wp-content/uploads/2019/12/Isaias-_-Abiy-_-Eritrean-President-_.jpg","width":600,"height":400,"caption":"Eritrean President _ Ethiopia"},{"@type":"WebPage","@id":"https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/#webpage","url":"https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/","inLanguage":"en-US","name":"Eritrean President : &quot;it was like a two months long visit&quot;","isPartOf":{"@id":"https://borkena.com/#website"},"primaryImageOfPage":{"@id":"https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/#primaryimage"},"datePublished":"2019-12-28T03:28:46+00:00","dateModified":"2019-12-28T03:28:50+00:00","description":"Eritrean President has concluded his working visit to Ethiopia. He reportedly said he felt as if it was two months. Read more."},{"@type":"Article","@id":"https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/#article","isPartOf":{"@id":"https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/#webpage"},"author":{"@id":"https://borkena.com/#/schema/person/c5d9fa307f8e5d28215a03a84ef4016b"},"headline":"Eritrean President : &#8220;it was like a two months long visit&#8221;","datePublished":"2019-12-28T03:28:46+00:00","dateModified":"2019-12-28T03:28:50+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/#webpage"},"publisher":{"@id":"https://borkena.com/#/schema/person/"},"image":{"@id":"https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/#primaryimage"},"articleSection":"Ethiopian News"},{"@type":["Person"],"@id":"https://borkena.com/#/schema/person/c5d9fa307f8e5d28215a03a84ef4016b","name":"Account","image":{"@type":"ImageObject","@id":"https://borkena.com/#authorlogo","url":"https://secure.gravatar.com/avatar/c1daaa6c5087862bf944bcebaa1e48b5?s=96&d=mm&r=g","caption":"Account"},"sameAs":[]}]}</script> <!-- / Yoast SEO Premium plugin. --><link rel="alternate" type="application/rss+xml" title="Borkena Ethiopian News &raquo; Feed" href="https://borkena.com/feed/" /><link rel="alternate" type="application/rss+xml" title="Borkena Ethiopian News &raquo; Comments Feed" href="https://borkena.com/comments/feed/" /><link rel="alternate" type="application/rss+xml" title="Borkena Ethiopian News &raquo; Eritrean President : &#8220;it was like a two months long visit&#8221; Comments Feed" href="https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/feed/" /><style type="text/css">img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><link rel='stylesheet' id='siteground-optimizer-combined-styles-header-css'  href='https://borkena.com/wp-content/uploads/siteground-optimizer-assets/siteground-optimizer-combined-styles-9a2b7afd50b6fa9c254cd454b466d8fa.css' type='text/css' media='all' /><link rel='stylesheet' id='gabfire_shortcodes-css'  href='https://borkena.com/wp-content/themes/adv-newspaper/framework/functions/css/shortcodes.css' type='text/css' media='all' /> <script type='text/javascript' src='https://borkena.com/wp-includes/js/jquery/jquery.js'></script> <script type='text/javascript' src='https://borkena.com/wp-includes/js/jquery/jquery-migrate.min.js'></script> <script type='text/javascript' src='https://borkena.com/wp-content/themes/adv-newspaper/inc/js/rslides.js'></script> <script type='text/javascript' src='https://borkena.com/wp-content/themes/adv-newspaper/inc/js/jquery.cycle2.min.js'></script> <script type='text/javascript' src='https://borkena.com/wp-content/themes/adv-newspaper/inc/js/owl.carousel.min.js'></script> <script type='text/javascript' src='https://borkena.com/wp-content/themes/adv-newspaper/framework/bootstrap/js/bootstrap.min.js'></script> <script type='text/javascript' src='https://borkena.com/wp-content/themes/adv-newspaper/inc/js/responsive-menu.js'></script> <link rel='https://api.w.org/' href='https://borkena.com/wp-json/' /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://borkena.com/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://borkena.com/wp-includes/wlwmanifest.xml" /><meta name="generator" content="WordPress 5.3.2" /><link rel='shortlink' href='https://borkena.com/?p=31586' /><link rel="alternate" type="application/json+oembed" href="https://borkena.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fborkena.com%2F2019%2F12%2F27%2Feritrean-president-it-was-like-a-two-months-long-visit%2F" /><link rel="alternate" type="text/xml+oembed" href="https://borkena.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fborkena.com%2F2019%2F12%2F27%2Feritrean-president-it-was-like-a-two-months-long-visit%2F&#038;format=xml" /><link rel="shortcut icon" href="https://borkena.com/wp-content/uploads/2015/04/borkena-logo-favicon.jpg"/> <!-- Custom Styling --><style type="text/css">.noborderli li {padding:10px 0 !important; border-bottom:1px solid #dfdfdf !important}</style> <script type='text/javascript'>(function($) {
				$(document).ready(function() { 
					$(".children").parent("li").addClass("has-child-menu");
					$(".sub-menu").parent("li").addClass("has-child-menu");
					$(".drop").parent("li").addClass("has-child-menu");
					
					$('.fadeimage').hover(
						function() {$(this).stop().animate({ opacity: 0.5 }, 800);},
						function() {$(this).stop().animate({ opacity: 1.0 }, 800);}
					);
					
					$('.mastheadnav li ul,.mainnav li ul,.subnav li ul,.mastheadnav li ul,.mainnav li ul,.productsnav li ul').hide().removeClass('fallback');
					$('.mastheadnav > li,.mainnav > li,.subnav > li,.mainnav > li,.productsnav > li ').hover(
						function () {
							$('ul', this).stop().slideDown(250);
						},
						function () {
							$('ul', this).stop().slideUp(250);
						}
					);						
					
					$('[data-toggle="tooltip"]').tooltip({
						'placement': 'top'
					});					
					
					/* Slide to ID & remove 80px as top offset (for navigation) when sliding down */
					$('a[href*=#respond]:not([href=#])').click(function() {
						if (location.pathname.replace(/^\//, '') == this.pathname.replace(/^\//, '') || location.hostname == this.hostname) {

							var target = $(this.hash);
							target = target.length ? target : $('[name=' + this.hash.slice(1) + ']');
							if (target.length) {
								$('html,body').animate({
									scrollTop: target.offset().top - 65
								}, 1000);
								return false;
							}
						}
					});						
					  $("#slides1").responsiveSlides({
						auto: true,
						timeout: 4000,
						pager: true, 
						nav: true,
						fade: 500,
						maxwidth: 800
					  });
					
					/* InnerPage Slider */
					var innerslider = $(".carousel-gallery");
					innerslider.owlCarousel({
					  autoPlay: 999999,
					  pagination:true,
					  singleItem : true,
					  autoHeight : true,
					  mouseDrag: false,
					  touchDrag: false					  
					});	
					$(".carousel-gallery-next").click(function(){
						innerslider.trigger('owl.next');
					});
					$(".carousel-gallery-prev").click(function(){
						innerslider.trigger('owl.prev');
					});
					
					/* InnerPage Slider */
					var owl4 = $(".carousel-four");
					owl4.owlCarousel({
					  autoPlay: 999999,
					  pagination:true,
					  singleItem : true,
					  autoHeight : true,
					  mouseDrag: false,
					  touchDrag: false					  
					});	
					$(".carousel-four-next").click(function(){
						owl4.trigger('owl.next');
					});
					$(".carousel-four-prev").click(function(){
						owl4.trigger('owl.prev');
					});						
					
					// Responsive Menu (TinyNav)
					$(".responsive_menu").tinyNav({
						active: 'current_page_item', // Set the "active" class for default menu
						label: ''
					});
					$(".tinynav").selectbox();			
					
					$('a[href=#top]').click(function(){
						$('html, body').animate({scrollTop:0}, 'slow');
						return false;
					});
					$(".showlogin,.showcoupon,.shipping-calculator-button").click(function(){
						$('.login').toggleclass();
					});	
					$('.type-product br,#ship-to-different-address br').remove();
				});
			})(jQuery);</script> <style type="text/css" id="custom-background-css">body.custom-background { background-image: url("https://borkena.com/wp-content/uploads/2019/08/Ethiopian-News-_-Ethiopia-News-Today-_-b.jpg"); background-position: left top; background-size: contain; background-repeat: no-repeat; background-attachment: fixed; }</style> <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <script>(adsbygoogle = window.adsbygoogle || []).push({
    google_ad_client: "ca-pub-6211574194789638",
    enable_page_level_ads: true
  });</script> </head><body class="post-template-default single single-post postid-31586 single-format-standard custom-background body-default" itemscope="itemscope" itemtype="http://schema.org/WebPage"><div class="container"><header itemscope="itemscope" itemtype="http://schema.org/WPHeader" role="banner"><div class="row"><!-- Site Masthead Row--><nav class="col-md-12 masthead-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation"><ul class="mastheadnav"><li><span class="arrow-right"></span></li><li class="masthead_date"> <script type="text/javascript"><!--
								var mydate=new Date()
								var year=mydate.getYear()
								if (year < 1000)
								year+=1900
								var day=mydate.getDay()
								var month=mydate.getMonth()
								var daym=mydate.getDate()
								if (daym<10)
								daym="0"+daym
								var dayarray=new Array("Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday")
								var montharray=new Array("January","February","March","April","May","June","July","August","September","October","November","December")
								document.write(""+dayarray[day]+", "+montharray[month]+" "+daym+", "+year+"")
								// --></script> </li><li class="pull-right social_header"> <a class="socialsite-facebook" href="https://www.facebook.com/pages/Borkena/294762583969356?ref=hl" title="Facebook" rel="nofollow"><span>Friend on Facebook</span> <i class="fa fa-facebook pull-left"></i> </a> <a class="socialsite-twitter" href="https://twitter.com/zborkena" title="Twitter" rel="nofollow"><span>Follow on Facebook</span> <i class="fa fa-twitter pull-left"></i> </a> <a class="socialsite-google" href="https://plus.google.com/110520803582687611762" title="Google+" rel="nofollow"><span>Add to Google+ Circle</span> <i class="fa fa-google-plus pull-left"></i> </a> <a class="socialsite-youtube" href="https://www.youtube.com/user/dbirku" title="Youtube" rel="nofollow"><span>Watch on YouTube</span> <i class="fa fa-youtube pull-left"></i> </a> <a class="socialsite-rss" href="https://borkena.com/" title="Site feed" rel="nofollow"> <span>Subscribe to RSS</span> <i class="fa fa-rss pull-left"></i> </a></li><li class="pull-right gab_headersearch"> <a data-toggle="modal" href="#searchModal"><i class="fa fa-search"></i> Search</a></li></ul></nav> <!-- Modal --><div class="modal fade" id="searchModal" tabindex="-1" role="dialog" aria-labelledby="myModalLabel" aria-hidden="true"><div class="modal-dialog"><div class="modal-content"><div class="modal-header"> <button type="button" class="close" data-dismiss="modal" aria-hidden="true">&times;</button><h4 class="modal-title">Search in Site</h4></div><div class="modal-body"><form action="https://borkena.com/"><div class="input-prepend"> <label>To search in site, type your keyword and hit enter</label> <input type="text" name="s" class="form-control" placeholder="Type keyword and hit enter"></div></form></div><div class="modal-footer"> <button type="button" class="btn btn-default" data-dismiss="modal">Close</button></div></div><!-- /.modal-content --></div><!-- /.modal-dialog --></div><!-- /.modal --></div><!-- /.row Site Masthead Row --><div class="row"><div class="col-lg-12"><div id="header"><div class="logo logo-banner pull-left" style="float:left;margin:0;padding:15px 0px 0px 0px;"><h1> <a href="https://borkena.com/" title="Latest Ethiopian News,Videos,Music,Sports,Travel,Business&amp; More"> <img src="https://borkena.com/wp-content/uploads/2018/03/Ethiopian-News-_Ethiopia.jpg" alt="Borkena Ethiopian News" title="Borkena Ethiopian News"/> </a></h1></div><!-- logo --><div class="header-ad pull-right logo-banner"><aside id="gabfire_simplead_widget-30" class="widget gabfire_simplead_widget"><div class="widgetinner"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- leaderboard main page responsive --> <ins class="adsbygoogle"
 style="display:inline-block;width:728px;height:90px"
 data-ad-client="ca-pub-6211574194789638"
 data-ad-slot="7187426706"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script><div class='clear'></div></div></aside></div><div class="clearfix"></div></div><!-- /header --></div><!-- /col-lg-12 --></div><!-- /row --><div class="row site-nav"><div class="col-lg-12"><nav class="main-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation"><ul class="mainnav responsive_menu"><li id="menu-item-16825" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-16825"><a href="https://borkena.com/">Home</a></li><li id="menu-item-9818" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-9818"><a title="Ethiopian News" href="https://borkena.com/latest-ethiopian-news/">Featured</a></li><li id="menu-item-26392" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-26392"><a href="https://borkena.com/ethiopian-news-today/">Latest</a></li><li id="menu-item-9942" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9942"><a title="Ethiopian News" href="https://borkena.com/ethiopian-news-3/">News</a></li><li id="menu-item-16909" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16909"><a href="https://borkena.com/business-ethiopia/">Business</a></li><li id="menu-item-9820" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-9820"><a href="https://borkena.com/opinion/">Opinion</a></li><li id="menu-item-14672" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-14672"><a title="Ethiopian Video" href="https://borkena.com/ethiopian-videos/">Video</a></li><li id="menu-item-13352" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-13352"><a href="http://amharic.borkena.com/">Amharic</a></li><li id="menu-item-16902" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16902"><a title="African News" href="https://borkena.com/ethiopian-news-today/africa/">Africa</a><ul class="sub-menu"><li id="menu-item-16901" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-home menu-item-16901"><a href="https://borkena.com/">World News</a></li><li id="menu-item-16906" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16906"><a href="https://borkena.com/middle-east/">Middle East &#038; Asia</a></li><li id="menu-item-16905" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16905"><a href="https://borkena.com/latin-america/">Latin America</a></li><li id="menu-item-16904" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16904"><a href="https://borkena.com/reports/">Europe</a></li><li id="menu-item-16903" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16903"><a href="https://borkena.com/canada/">Canada &#038; US</a></li></ul></li><li id="menu-item-16585" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-16585"><a title="Ethiopian Music and Comedy" href="https://borkena.com/ethiopian-music-drama-show/">Entertainment</a><ul class="sub-menu"><li id="menu-item-16849" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16849"><a href="https://borkena.com/ethiopian-restaurant/">Restaurant</a></li><li id="menu-item-16848" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16848"><a title="Travel Ethiopia " href="https://borkena.com/travel/">Travel</a></li><li id="menu-item-16588" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16588"><a href="https://borkena.com/sport/">Sport</a></li><li id="menu-item-16908" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16908"><a href="https://borkena.com/books/">Books</a></li><li id="menu-item-17039" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17039"><a href="https://borkena.com/ethiopian-bloggers/">Blog</a></li></ul></li><li id="menu-item-28770" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28770"><a href="https://borkena.com/disclaimer/">Disclaimer</a></li><li id="menu-item-16910" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16910"><a href="https://borkena.com/contact-us/">Contact</a></li></ul></nav><nav class="secondary-navigation" itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation"><ul class="subnav responsive_menu"></ul></nav></div></div></header><div class="row default"><main class="col-xs-12 col-md-8 col-sm-8 post-wrapper" role="main" itemprop="mainContentOfPage" itemscope="itemscope" itemtype="http://schema.org/Blog"><div class="row"><div class="col-lg-12 col-md-12"><div class="post-lead"><h1 class="entry-title single-post-title" itemprop="headline"> Eritrean President : &#8220;it was like a two months long visit&#8221;</h1><aside id="gabfire_simplead_widget-28" class="widget gabfire_simplead_widget"><div class="widgetinner"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- Post entrance before top --> <ins class="adsbygoogle"
 style="display:block"
 data-ad-client="ca-pub-6211574194789638"
 data-ad-slot="4588459509"
 data-ad-format="auto"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script><div class='clear'></div></div></aside></div></div></div><section class="article-wrapper"><article itemscope="itemscope" itemtype="http://schema.org/BlogPosting" itemprop="blogPost" class="entry post-31586 post type-post status-publish format-standard has-post-thumbnail hentry category-latest-ethiopian-news last_archivepost"><div class="social-sharethis-post"> <a href="http://www.facebook.com/sharer.php?u=https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/&t=Eritrean President : &#8220;it was like a two months long visit&#8221;" data-toggle="tooltip" title="Share on Facebook" rel="nofollow"><span>Share on Facebook</span> <i class="fa fa-facebook pull-left"></i> </a> <a href="http://twitter.com/home?status=Eritrean President : &#8220;it was like a two months long visit&#8221; => https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/" data-toggle="tooltip" title="Share on Twitter" rel="nofollow"><span>Follow on Facebook</span> <i class="fa fa-twitter pull-left"></i> </a> <a href="https://plus.google.com/share?url=https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/" data-toggle="tooltip" title="Share on Google+" rel="nofollow"><span>Add to Google+</span> <i class="fa fa-google-plus pull-left"></i> </a> <a href="http://www.linkedin.com/shareArticle?mini=true&url=https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/&title=Eritrean President : &#8220;it was like a two months long visit&#8221;&summary=&source=Borkena Ethiopian News" data-toggle="tooltip" title="Share on LinkedIn" rel="nofollow"><span>Connect on Linked in</span> <i class="fa fa-linkedin pull-left"></i> </a> <a class="pull-right" href="mailto:?mailto:?subject=Borkena%20Ethiopian%20News%20%3A%20Eritrean%20President%20%3A%20%26quot%3Bit%20was%20like%20a%20two%20months%20long%20visit%26quot%3B&amp;body=I%20recommend%20this%20page%3A%20Eritrean%20President%20%3A%20%26quot%3Bit%20was%20like%20a%20two%20months%20long%20visit%26quot%3B.%0AYou%20can%20read%20it%20on%3A%20https%3A%2F%2Fborkena.com%2F2019%2F12%2F27%2Feritrean-president-it-was-like-a-two-months-long-visit%2F" data-toggle="tooltip" title="Send by Email" rel="nofollow"><span>Subscribe by Email</span> <i class="fa fa-envelope-o pull-left"></i> </a> <a class="pull-right" href="javascript:window.print()" data-toggle="tooltip" title="Print This Post" rel="nofollow"><span>Print This Post</span> <i class="fa fa-print pull-left"></i> </a></div><div class="clearfix"></div><div class="entry-content" itemprop="text"><p>Eritrean President speaks as if he was impressed with his latest visit to Ethiopia</p><div class="wp-block-image"><figure class="aligncenter size-large"><img src="https://borkena.com/wp-content/uploads/2019/12/Isaias-_-Abiy-_-Eritrean-President-_.jpg" alt="Eritrean President _ PM Abiy  " class="wp-image-31587" srcset="https://borkena.com/wp-content/uploads/2019/12/Isaias-_-Abiy-_-Eritrean-President-_.jpg 600w, https://borkena.com/wp-content/uploads/2019/12/Isaias-_-Abiy-_-Eritrean-President-_-450x300.jpg 450w, https://borkena.com/wp-content/uploads/2019/12/Isaias-_-Abiy-_-Eritrean-President-_-570x380.jpg 570w" sizes="(max-width: 600px) 100vw, 600px" /><figcaption>Photo credit : OPM</figcaption></figure></div><p>borkena<br />December 27, 2019</p><p>Eritrean President Isaias Afeworki has arrived in Asmara on Friday Morning after concluding three days off an official working visit to Ethiopia.</p><p>He was seen off by Prime Minister Abiy Ahmed at Bole International Airport in Addis Ababa.</p><p>His visit was packed with events &#8211; ceremonial ones as well as serious ones like meeting with Prime Abiy Ahmed, apparently it was a closed meeting. They reportedly discussed ways of strengthening bilateral relations between the two countries.</p><p>He has also visited industrial sites within 100 kilometers range of Ethiopia&#8217;s capital. Adama Industrial Park, Industrial projects in Dukem and Bishoftu (Debrezeit) are some of the projects he and his delegation visited during the second day of the visit on Thursday.</p><p>In the afternoon, he has to lay the foundation stone for the construction of a new <a href="https://borkena.com/2019/12/26/eritrean-embassy-construction-cornerstone-laid-in-addis-ababa/" target="_blank" rel="noreferrer noopener" aria-label="Eritrean Embassy  (opens in a new tab)">Eritrean Embassy </a>building near Hamle 19 recreation park in sidist kilo area of the city.  He was joined by Abiy Ahmed who said: &#8220;it is a Christmas gift for the people and the government of Eritrea.&#8221;</p><p>The day was wrapped up with a dinner invitation for the Eritrean delegation at the National Palace. The dinner event was labeled as &#8220;Let’s celebrate shared historical chapter.”&nbsp; President Sahle-Work Zewdie and Deputy Prime Minister Demeke Mekonen, among other senior-level Ethiopian government officials, attended it.</p><p>&#8220;My two days of visit felt like two months; it was filled with several surprise events, &#8220;state-affiliated Fana Broadcasting Corporate (FBC) cited president Isaias as saying. It is unclear if he was being sarcastic about it.</p><p>Yet, viewed from the business of his visit which was to bolster ties between the two countries, it seems it has achieved its purpose. In a new update published on Friday, The Ministry of Information of Eritrea said: &#8220;President Isaias and Prime Minister Abiy Ahmed underlined that both Governments are working to redouble efforts to achieve peace and develop strong bilateral cooperation in several sectors.&#8221; He is also cited by Ethiopian media as saying the three generations of time is lost between the two countries.</p><p>President Isaias Afeworki has visited Ethiopia at least four times since Ethiopia and Eritrea signed friendship and peace agreement in July of 2018.</p><p>A considerable number of Ethiopians see his visit in a positive light. Others, especially those who are indifferent to politics, see his visit with indifference.</p><p>Still others tend to see his visit with anger and hate. A prominent pro-TPLF digital news portal, <a rel="noreferrer noopener" aria-label="Tigrai Online (opens in a new tab)" href="http://www.tigraionline.com/" target="_blank">Tigrai Online</a> , wrote on December 27 : &#8220;The real reason for Isaias Afwerki’s visit is to reassure the masters of the Middle East and the Western world there is no crack between Isaias and Abiyot Ahmed.”</p><p>The article itself is given the title  &#8220;The destructive symbiotic relation of Isaias Afwerki and Abiyot Ahmed.&#8221; </p><p>While it described Abiy Ahmed as &#8220;low-level security officer&#8230;who was spying for foreign governments came to power in Ethiopia,&#8221; Eritrean President is labeled as &#8220;leader of the African North Korea&#8221; </p><p><script async="" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <ins class="adsbygoogle" style="display:block; text-align:center;" data-ad-layout="in-article" data-ad-format="fluid" data-ad-client="ca-pub-6211574194789638" data-ad-slot="1131001194"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script></p><p>Join the conversation. <a rel="noreferrer noopener" href="https://www.facebook.com/Ethiopiannewsborkena/" target="_blank">Like borkena on Facebook and get Ethiopian News updates regularly</a>. As well, you may get Ethiopia News by following us on twitter <a rel="noreferrer noopener" href="https://twitter.com/zborkena" target="_blank">@zborkena</a></p></div><aside id="gabfire_share_widget-3" class="widget gabfire_share_widget"><div class="widgetinner"><div class="gab_share_boxes"><div class="google-share-box"><div class="g-plusone" data-size="tall"></div></div><div class="facebook-share-box"><div class="fb-like" data-href="https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/" data-send="false" data-layout="box_count" data-width="65" data-show-faces="false"></div></div><div class="twitter-share-box"><a href="https://twitter.com/share" class="twitter-share-button" data-url="https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/" data-counturl="https://borkena.com/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/" data-text="Eritrean President : &#8220;it was like a two months long visit&#8221;" data-lang="en" data-related="anywhereTheJavascriptAPI" data-count="vertical">Tweet</a></div><div class="linkedin-share-box"><script type="IN/Share" data-url="www.gabfirethemes.com" data-counter="top"></script></div><div class="pinterest-share-box"><a href="http://pinterest.com/pin/create/button/?url=https%3A%2F%2Fborkena.com%2F2019%2F12%2F27%2Feritrean-president-it-was-like-a-two-months-long-visit%2F&media=https%3A%2F%2Fborkena.com%2Fwp-content%2Fuploads%2F2019%2F12%2FIsaias-_-Abiy-_-Eritrean-President-_-450x300.jpg&description=Eritrean President speaks as if he was impressed with his latest visit to Ethiopia borkenaDecember 27, 2019 Eritrean President Isaias Afeworki has arrived in Asmara on Friday Morning after concluding three days off an official working visit to Ethiopia. He was seen off by Prime Minister Abiy Ahmed at Bole International Airport in Addis Ababa. [&hellip;]" class="pin-it-button" count-layout="horizontal"><img border="0" src="//assets.pinterest.com/images/PinExt.png" title="Pin It" /></a></div></div><div class="clearfix"></div><div class="clear clearfix"></div><div class='clear'></div></div></aside><aside id="text-3" class="widget widget_text"><div class="widgetinner"><div class="textwidget"><p><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script><br /> <ins class="adsbygoogle"
 style="display:block"
 data-ad-format="autorelaxed"
 data-ad-client="ca-pub-6211574194789638"
 data-ad-slot="3129768139"></ins><br /> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script> </p></div></div></aside><div id="comments" class="gabfire-comments"><div id="respond" class="comment-respond"><h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2019/12/27/eritrean-president-it-was-like-a-two-months-long-visit/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://borkena.com/wp-comments-post.php" method="post" id="commentform" class="comment-form" novalidate><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><textarea id="comment" placeholder="Add your comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><div class="form-field-wrapper"><div class="input-group"><span class="input-group-addon"><i class="fa fa-user"></i></span><input class="form-control" id="author" name="author" type="text" placeholder="Name" value="" /></div></div><div class="form-field-wrapper mid-input-item"><div class="input-group"><span class="input-group-addon"><i class="fa fa-envelope"></i></span><input class="form-control" id="email" name="email" type="text" placeholder="Email" value=""  /></div></div><div class="form-field-wrapper"><div class="input-group"><span class="input-group-addon"><i class="fa fa-home"></i></span><input class="form-control" placeholder="Website" id="url" name="url" type="text" value="" size="30" /></div></div><p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /> <label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Post Comment" /> <input type='hidden' name='comment_post_ID' value='31586' id='comment_post_ID' /> <input type='hidden' name='comment_parent' id='comment_parent' value='0' /></p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="cbc2e17cd4" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="81"/></p></form></div><!-- #respond --></div><!-- #comments --></article></section><!-- articles-wrapper --></main><!-- col-md-8 --><div class="col-md-4 col-sm-4 col-xs-12 sidebar-wrapper"><div class="sidebar" role="complementary" itemscope="itemscope" itemtype="http://schema.org/WPSideBar"><aside id="gabfire_simplead_widget-21" class="widget gabfire_simplead_widget"><div class="widgetinner"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script> <!-- Inner SB Skyscraper --> <ins class="adsbygoogle"
 style="display:inline-block;width:300px;height:600px"
 data-ad-client="ca-pub-6211574194789638"
 data-ad-slot="6286370702"></ins> <script>(adsbygoogle = window.adsbygoogle || []).push({});</script><div class='clear'></div></div></aside><aside id="gabfire_social_widget-3" class="widget gabfire_social_widget"><div class="widgetinner"><a target="_blank" class="facebook" href="https://www.facebook.com/pages/Borkena/294762583969356?ref=hl" rel="nofollow">Facebook</a><a target="_blank" class="twitter" href="https://twitter.com/zborkena" rel="nofollow">Twitter</a><a target="_blank" class="instagram" href="https://www.instagram.com/zborkena/" rel="nofollow">instagram</a><a target="_blank" class="plus1" href="https://plus.google.com/110520803582687611762" rel="nofollow">Google +1</a><a target="_blank" class="youtube" href="https://www.youtube.com/user/dbirku" rel="nofollow">Youtube</a><div class="clear clearfix"></div><div class='clear'></div></div></aside></div></div></div><footer role="contentinfo" itemscope="itemscope" itemtype="http://schema.org/WPFooter"><div class="row footercats"><div class="col-md-12"><ul itemscope="itemscope" itemtype="http://schema.org/SiteNavigationElement" role="navigation"><li id="menu-item-28750" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28750"><a href="https://borkena.com/photography/">Photography</a></li><li id="menu-item-16350" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-16350"><a href="https://borkena.com/scholarships/">Scholarships</a></li><li id="menu-item-28749" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-28749"><a href="https://borkena.com/disclaimer/">Disclaimer</a></li></ul></div></div><div class="footer-firstrow row"><div class="col-md-4 col-lg-4 col-sm-3 col-xs-12 footer-firstrow-widget"><aside id="gabfire_social_widget-2" class="widget gabfire_social_widget"><div class="widgetinner"><h3 class="widgettitle">Follow us</h3> <a target="_blank" class="facebook" href="https://www.facebook.com/pages/Borkena/294762583969356?ref=hl" rel="nofollow">Facebook</a><a target="_blank" class="twitter" href="https://twitter.com/zborkena" rel="nofollow">Twitter</a><a target="_blank" class="instagram" href="https://www.instagram.com/zborkena/" rel="nofollow">instagram</a><a target="_blank" class="plus1" href="https://plus.google.com/110520803582687611762" rel="nofollow">Google +1</a><a target="_blank" class="youtube" href="https://www.youtube.com/user/dbirku" rel="nofollow">Youtube</a><div class="clear clearfix"></div><div class='clear'></div></div></aside></div><div class="col-md-4 col-lg-4 col-sm-4 col-xs-12 footer-firstrow-widget footer-mid-column"><aside id="gab_contact_widget-2" class="widget gab_contact_widget"><div class="widgetinner"><h3 class="widgettitle">Contact Us</h3><div class='gab_contact_logocont'><img src='https://borkena.com/wp-content/uploads/2015/04/borkena-logo-favicon.jpg' class='aligncenter' alt='Borkena Ethiopian News' /></div><address><a href='mailto:info@borkena.com'>info@borkena.com</a><br /></address><div class='clear'></div></div></aside></div><div class="col-md-4 col-lg-4 col-sm-5 col-xs-12 footer-firstrow-widget"><aside id="gabfire_search_widget-3" class="widget gabfire_search_widget"><div class="widgetinner"><h3 class="widgettitle">Search in Site</h3><form class="gabfire_search_style1" action="https://borkena.com/"><fieldset style="background:#efefef;border:1px solid #eee;"> <input type="text" style="width:80%;background:#efefef" class="gab_search_text" name="s" value="Search..." onfocus="if (this.value == 'Search...') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search...';}" /> <input type="submit" class="submit_style1" alt="Search..." /><div class="clearfix"></div></fieldset></form><div class='clear'></div></div></aside></div></div><div class="row footer-meta-wrapper"><div class="col-md-12"><div class="footer-meta"><div class="footer-metaleft pull-left"> &copy; 2019, <a href="#top" title="Borkena Ethiopian News" rel="home"><strong>&uarr;</strong> Borkena Ethiopian News</a></div><!-- #site-info --><div class="footer-metaleft pull-right"> <a rel="nofollow" href="https://borkena.com/wp-login.php">Log in</a> - <script type="text/javascript"><!--
		  (function() {
			var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
			po.src = 'https://apis.google.com/js/plusone.js';
			var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
		  })();
		  // --></script> <div id="fb-root"></div> <script type='text/javascript'><!--
		(function(d, s, id) {
		  var js, fjs = d.getElementsByTagName(s)[0];
		  if (d.getElementById(id)) return;
		  js = d.createElement(s); js.id = id;
		  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
		  fjs.parentNode.insertBefore(js, fjs);
		}(document, 'script', 'facebook-jssdk'));
		// --></script> <script type='text/javascript'><!--
		!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src="//platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");
		// --></script> <script src="//platform.linkedin.com/in.js" type="text/javascript">lang: en_US</script> <script type="text/javascript" src="//assets.pinterest.com/js/pinit.js"></script> <script type="text/javascript" src="//assets.pinterest.com/js/pinit.js"><!--
			document.body.innerHTML = document.body.innerHTML.replace(/&amp;;/g, "a");
		// --></script> <script type='text/javascript' src='https://borkena.com/wp-content/plugins/gabfire-widget-pack/js/jquery.tools.min.js'></script> <script type='text/javascript' src='https://borkena.com/wp-includes/js/comment-reply.min.js'></script> <script type='text/javascript' src='https://borkena.com/wp-includes/js/wp-embed.min.js'></script> <script async="async" type='text/javascript' src='https://borkena.com/wp-content/plugins/akismet/_inc/form.js'></script> </div> <!-- #footer-right-side --></div></div></div></footer><!-- /footer --></div><!-- /container --></body></html>
<!-- This website is like a Rocket, isn't it? Performance optimized by WP Rocket. Learn more: https://wp-rocket.me - Debug: cached@1577508978 -->